Yeelight v1 bulbs not found

I have been trying to add yeelight v1 bulbs to my setup but they do not show up when looking for new lights.

I run the emulator in a docker container (latest version) on my desktop connected to the network over ethernet. I have been able to add DIY (esp8266) lights to the bridge emulator, so the setup is atleast partially functioning. The yeelight bulbs are in LAN mode and have been upgraded to the latest firmware. So far I have tried rebooting and resetting the bulbs, rebooting the container, moving the bulb next to the router and updating firmware on the bulbs. I have ran out of troubleshooting steps and am wondering if anyone here has ran into similar problems and could possible offer a solution.

One clue to the problem might be that there are some 404 errors that occur in the emulator everytime I try looking for lights:
172.17.0.1 - - [03/Mar/2021 18:16:29] “POST /api/hueess787b6f11ebb8490242ac110002/lights HTTP/1.1” 200 -

    172.17.0.1 - - [03/Mar/2021 18:16:31] "GET /api/hueess787b6f11ebb8490242ac110002 HTTP/1.1" 200 -

    {"ok"}

    172.17.0.1 - - [03/Mar/2021 18:16:35] "GET /text_sensor/light_id HTTP/1.1" 200 -

    172.17.0.1 - - [03/Mar/2021 18:16:35] code 404, message not found

    172.17.0.1 - - [03/Mar/2021 18:16:35] "GET /cm?cmnd=Status%200 HTTP/1.1" 404 -

    172.17.0.1 - - [03/Mar/2021 18:16:35] code 404, message not found

    172.17.0.1 - - [03/Mar/2021 18:16:35] "GET /shelly HTTP/1.1" 404 -

    172.17.0.1 - - [03/Mar/2021 18:16:36] "GET /api/hueess787b6f11ebb8490242ac110002/lights/new HTTP/1.1" 200 -

    172.17.0.1 - - [03/Mar/2021 18:16:37] "GET /api/3198d7f07c4a11ebafcc0242ac110002/ HTTP/1.1" 200 -

You are running in Docker mode, correct? What command did you use to start your container?

That is correct. The command I used was
docker run -d --name diyHue --restart=always --network=bridge -v export:/opt/hue-emulator/export -e MAC=<mac> -e IP=<ip> -e DECONZ=<ip> -p 80:80/tcp -p 443:443/tcp -p 1900:1900/udp -p 2100:2100/udp -p 1982:1982/udp diyhue/core:latest

You cannot specify an IP and mac address for the default bridge network. If you want to specify the IP address used in the internal network for a bridge network, you have to create your own. Also, using the bridge network will mean that the IP address assigned to DIYHue will be within the bridge network. So, something like 172.17.0.6. I would recommend running in Host mode.

docker run -d --name “diyHue” --restart=“always” --network=“host” -v ‘/mnt/hue-emulator/export/’:’/opt/hue-emulator/export/’:‘rw’ diyhue/core:latest

If DIYHue might only be scanning for bulbs within the bridge network and the your lan.