DiyHue Bridge doesnt find lights and cant pair with original Bridge

Hey there,
I had all of my stuff working for over half a year but now I needed to set the whole thing up again because I needed to reinstall the Raspberry Pi OS 32-bit on my Pi 4b.

I set it up via docker via:
docker run -d --name diyHue --restart=always --network=bridge -v /mnt/hue-emulator/config:/opt/hue-emulator/config -e MAC=e4:5f:01:ad:fa:ce -e IP= -p 80:80/tcp -p 443:443/tcp -p 1900:1900/udp -p 2100:2100/udp -p 1982:1982/udp diyhue/core:latest
with the mac- and IP-address of my Pi.

I added the bridge after deleting the old one from the app and I can access the web-interface.

Now here’s my Problem:
It does not find any lights (all original hue) via the app or web-interface.
I scanned multiple times, turned the Lights off and on again, even tried directly connecting to the serial number.
All without any success.

Next thing I tried was pairing the original Hue Bridge via the web-interface.
My original Bridge is at the IP so I typed that in and hit “Pair”.

It instantly responds with the message “Network Error”.

No Idea why, I rebooted the Pi a bunch of times and tried again and again.
Nothing seems to work.

I hope some savant can help me out or at least nudge me in the right direction because im more of a novice when it comes to Linux based stuff ^^"

Thanks in advance!

I got it to work now.
All the times I tried to pair the original Bridge before I went to the web-interface on my computer instead of the Pi itself.

I was able to pair the Bridge in the browser of the Pi. (It said Link button not pressed instead of Network error all the time) I pressed the Link button on the original Bridge and it Paired flawlessly.

Hope this helps someone in some capacity.

1 Like