Cant Connect to Hue App

@cinghialino I would suggest we keep your Troubleshooting in a new Topic.

You can start the (host) emulator with --debug true argument. or in docker check the docker logs with

sudo docker logs diyHue-beta -f

Lets see what the output shows upon trying to pair and when you press the Link button.

1 Like

for live support and troubleshooting you can also contact us on

thank you. I think I will make another attempt with a fresh SD card and, if getting the same results, Will install docker on RaspPi and try that route.
I’ll get back to you here once I have more data

1 Like

@cinghialino how is the progress?

I’ve installed docker, made the container run, but now (since I am experiencing the “Oops, there appears to be no lighting here”, I have to update the configuration to reflect v2 API, as referenced here)

Basically, I can’t find the configuration. The docs are lacking this info.

so, I’m stuck…

update: I’ve found the config (the first time I ran the command sudo docker run -d --name diyHue --restart=always --network=host -e MAC=(my MAC ADDRESS) -v /mnt/hue-emulator/config:/opt/hue-emulator/config diyhue/core:latest it didn’t create /mnt/hue-emulator/config/ at all)

so now I have stopped the container, edited the config.json to reflect

API : 1.49.0
Software Version: 1949203030

and restarted the container, but when I visit [IP address]/hue/linkbutton I still get the dreaded “Oops, there appears to be no lighting here”

I managed to solve it by not going to [IP]/hue/linkbutton but directly to the IP address of diyHue.

I guess I can take it from here. Thanks

This is actually the correct way as the root url delivers the web ui and all subd URLs are loaded Inline.