Diyhue Bridge (working)/WS2812B light (working) but not together

I currently have the following setup (both in the same subnet @ home)
raspberry pi zero with diyhue (automatic install) with ip 205, i can access the webbrowser of this ip and can link with my app. This raspberry pi zero has also nmap installed.

Next to this i have one nodemcu with WS2812 light (ip 222) that i also can connect with the webbrowser (port 80). In dit minimal webbrowser i can change the color of the light, on/off, etc. (https://github.com/mariusmotea/diyHue/blob/676aff78f54dc9e58b3f28f94c05b13d63e8cf28/Lights/Arduino/WS2812BHueStrip/WS2812BHueStrip.ino)

Both are checked with a desktop computer with ip 223.

On the diyhue bridge (205) i can ping/nmap the ws2812 light on ip 222.
pi@raspberrypi:~/diyHue/BridgeEmulator $ nmap -F 192.168.178.222
Starting Nmap 7.70 ( https://nmap.org ) at 2020-03-04 14:06 GMT
Nmap scan report for xxx.xxx.xxx.222
Host is up (0.022s latency).
Not shown: 99 closed ports
PORT STATE SERVICE
80/tcp open http

However, my apps on my iphone/android (hue essentials and others) and pc (lamp-finder) don’t recognize my lamp but i can connect to my bridge.

Have you tried “Add Lights” in the Hue app itself?

I am seeing the same thing. I used the diyhue WS2812 sketch and a wemos D1 mini and I am unable to find this light when I search in the hue app. I can find the device fine on my network but Hue doesn’t seem able to discover it. I am using the latest WS2812 sketch on the DIYHue lights github. Nothing shows up in the logs for the IP address in question so I don’t really have any logs to show. Is there something that I have to enable to find wifi lights like I used to? I’m going to try and manually add it to my config but that really shouldn’t be necessary, should it?

Hi, I have the same problem. Just deleted a led strip and wanted to reconnect it, but the bridge can’t find it anymore. I didn’t change anything. If I go directly to the lights ip-adress it works and I can control the light, but the hue app can’t find it. I have an other led strip (same setup) still connected to the bridge and works fine.

I tried to reset it, gave it an other ip-adress and restarted the router. but no luck… any ideas?