DiyHue errors on mulitiple instances

I have some trouble to re-install DiyHue. I had it running on a VM via Docker.
I wanted to re-install so i removed container etc etc . That didnt work. It gives the same error messages as here.

To my surprise i can also use it with home assistant ( i didnt know) so i thought this should be better but the same error codes.

Searched Google bur couldnt find something.

024-07-07 21:08:44,708 - services.updateManager - INFO - swversion number update from Philips, old: 1962154010 new:1965053020
2024-07-07 21:08:44,834 - services.updateManager - INFO - creation_time diyHue : 2024-07-07 19
2024-07-07 21:08:44,835 - services.updateManager - INFO - publish_time diyHue : 1970-01-01 00:00:00.000000000 +0100
2024-07-07 21:08:44,949 - services.updateManager - INFO - creation_time UI : 2024-07-07 19
Traceback (most recent call last):
File “/opt/hue-emulator/”, line 115, in
File “/opt/hue-emulator/services/”, line 104, in startupCheck
File “/opt/hue-emulator/services/”, line 56, in githubCheck
elif githubUICheck() == True:
File “/opt/hue-emulator/services/”, line 85, in githubUICheck“publish_time UI : " + str(publish_time))
UnboundLocalError: local variable ‘publish_time’ referenced before assignment
Exception ignored in: <function Group.del at 0x7fa97d9dc0>
2024-07-07 21:08:45,069 - HueObjects - INFO - Daylight sensor was destroyed.
Traceback (most recent call last):
File “/opt/hue-emulator/HueObjects/”, line 1051, in del
ImportError: sys.meta_path is None, Python is likely shutting down
— Logging error —
Traceback (most recent call last):
File “/usr/local/lib/python3.8/logging/”, line 69, in emit
if self.shouldRollover(record):
File “/usr/local/lib/python3.8/logging/”, line 183, in shouldRollover = self._open()
File “/usr/local/lib/python3.8/logging/”, line 1172, in _open
return open(self.baseFilename, self.mode, encoding=self.encoding)
NameError: name ‘open’ is not defined
Call stack:
File “/opt/hue-emulator/HueObjects/”, line 1755, in del + " sensor was destroyed.”)
Message: ‘Daylight sensor was destroyed.’
Arguments: ()
[cmd] ./ exited 1
[cont-finish.d] executing container finish scripts…
[cont-finish.d] executing…


The webpage is online now… but in the diyhue webpage the discovery button is not switching to on…hue app cant find the instancE?

Sometimes the webpages start…but after two or three restarts it fails.

Problem is solved in Github