Errors in the installation script, and no bridge detection with Ambilight Philips TV

Hi. First of all, congratulations on the work and support of this great project. Second, apologize for my English, I must use google translate.
I have installed DiyHue on a Raspberry Pi 3B (Buster), installed the system from 0, in host mode.
I have obtained these errors during the execution of the installation script, when installing WebSocket for Python:

byte-compiling build/bdist.linux-armv7l/egg/ws4py/ to async_websocket.cpython-37.pyc
  File "build/bdist.linux-armv7l/egg/ws4py/", line 87
SyntaxError: invalid syntax
byte-compiling build/bdist.linux-armv7l/egg/ws4py/server/ to tulipserver.cpython-37.pyc
  File "build/bdist.linux-armv7l/egg/ws4py/server/", line 43
    f = asyncio.async(self.handle_initial_handshake())
SyntaxError: invalid syntax

After this everything seems to work fine. I can connect the Hue app on Iphone, it detects the lights I have (Yeelight), everything is ok.

The next thing I do is try to add connect the hub with the Philips Ambilight TV (55PUS6704/12) and it doesn’t detect the hub. I have made several connection attempts as I read in the forum but it does not work. The TV has no option to indicate the ip of the hub.

I activate debug mode, I disconnect internet from the TV and when I make a new connection attempt, this error appears: - - [06/Feb/2020 17:28:50] "GET /description.xml HTTP/1.1" 200 -
Exception happened during processing of request from ('', 60104)
Traceback (most recent call last):
  File "/usr/lib/python3.7/", line 650, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib/python3.7/", line 360, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/lib/python3.7/", line 720, in __init__
  File "/usr/lib/python3.7/http/", line 428, in handle
  File "/usr/lib/python3.7/http/", line 394, in handle_one_request
    self.raw_requestline = self.rfile.readline(65537)
  File "/usr/lib/python3.7/", line 589, in readinto
    return self._sock.recv_into(b)
ConnectionResetError: [Errno 104] Connection reset by peer
---------------------------------------- - - [06/Feb/2020 17:28:50] "GET /description.xml HTTP/1.1" 200 -
2020-02-06 17:29:00,120 - urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1):
2020-02-06 17:29:00,587 - urllib3.connectionpool - DEBUG - "POST / HTTP/1.1" 200 6

Both the bridge and the TV are connected by cable (not WiFi) to the same switch. I’ve also tried to press the LinkButton while searching for the hub but nothing, it doesn’t work.

I do not know if the error in the installation of the script may have something to do. If I’m not already lost, I have looked in the github, in the forum, for slack, but I can’t find anything useful (or I haven’t seen it).

Any ideas?
Thanks in advance

I am also interested in using my Ambilight TVs with DiyHue. Sadly I can’t test this as both my TVs won’t connect to any Hue bridge since the last update in Dec 2019 (TPM171E_R. Philips have provided me a patch but that hasn’t worked either. I wonder if this is also your issue?

I run Deconz in Docker on my Synology which isn’t using default Deconz port due to port 80 being in use by Synology OS. Is it possible to specify a port with the --deconz parameter?