SK6812 Light doesn't respond to Alexa, if the LightCount is higher then 1

Hey everyone,

I tried a lot with the SK6812 Sketches and realised, if the LightCount is higher then 1, Alexa say’s the Device doesn’t respond. But it works it’s just really annoying, if you say “Alexa, HQ green” and Alexa answers: “The Device is not responding please check your network…” (It’s not exaclty what she says, i translated it from German and out of my mind, but i guess you know what i mean)

However using a Neopixel Strip without multiple simulated Lights, doesn’t make sense.

Is there any fix out there or has someone an Idea.

Thank you!

I’m a little confused. You say that the light changes but Alexa doesn’t think it does? Is the light changing within the Hue App? Are you connecting Alexa directly to DIYHue or through a 3rd party service, like HA or Hubitat?

excalty, it changes but Alexa thinks and says it doesn’t. The Color is changing in the App. Alexa is directly connected to DIYHue on a Raspberry PI.

I think, it’s maybe because, the 3 Virtual Lights, have the same IP address and this confuses Alexa ??

I don’t really know.

Hi @ryan780 thanks for your help!

I figured it out, because I used a wrong Power Supply and powered the Microcontroller with the same Power. It was not enough to send the Answer back to Alexa.

I also think, that it worked with only one Virtual Light, because it was Luck or because the Microcontroller has to answer only one request.

Thank you for your Help!