Sk6812 W output?

Hi there,
is it just me or does the hue essentials app or rather the code not utilize the white led in the sk6812?
Just wondering if you guys observed the same?
And if so do you have any suggestions, what i need to change for them to work?

Which sketch did you load onto your board? It doesn’t matter what DIYHue or the Hue essentials app do, it’s the board that controls the strip that determines what LEDs go on at what intensity. So, first order of business is making sure you used the right sketch and have it set up correctly.

Also, what color or color temp are you requesting the lights to come on to? White isn’t needed if you request pure red, obviously. So, it will also be dependent on what you have requested the light to come on to.

The best way to eliminate DIYHue from the mix is to use the web interface for the light directly., That will give you the most granular control over the light.

Thanks for your reply.
I am using the most recent code from github for the generic sk6812. Theres no difference using it in the web ui, checked it also before writing this whole post.

Feels really weird to me because the code seems fine to me…

What color are you requesting from the webUI? It appears to me that if you are ordering an RGB color, the white pixel will not be used. It would only be used for CT settings. But I am not certain of that.

Is there a Fix for that at the moment ? I have the Same problem, if i request a White Color, i get an Orange to Red mix.

I bought this [Strip] (
and used the “Generic_SK6812_Strip” Code.
I counted every LED and have 162 LED’s in total.

char *lightName = “Hue SK6812 strip”;
uint8_t scene, startup, onPin = 4, offPin = 5;
bool hwSwitch = false;

uint8_t lightsCount = 1;
uint16_t pixelCount = 162, lightLedsCount;
uint8_t transitionLeds = 6; // must be even number

But it is always some Orange - Red mix

I wanted to try it out on the WebUI, but there is only the new Colorwheel.

Thank you!

Hello everyone, I recently wrote a Post about my Problem.

I tried a little bit around and i think i figured it out.

So for everyone who still has problems with it, maybe this helps.

I used a wrong Powersupply my LED Strip (SK6812) with 162 LED’s in this Setup need’s min 8 Ampere i think i better go up to 10 or 12 Ampere because it was calculated for 144 LED’s 8.6Ampere

I wired the Strip directly to the Strip and only run a GND and Data Cable to the Wemos D1 Mini and powering the D1 Mini via USB.

And now i get a beautiful Warm White and Cold White.

I’m trying to get everything on one PCB and only one Power Supply, but for now it works and looks beautiful.

Hope I could help someone, who’s looking for a Solution!

Sorry for answering just now… had stuff to do.

I am controlling the light with the Hue essential app.
Am I correct in thinking that the app can’t controll those CT settings?

Yes, it can. And with the Generic SK6812 sketch it should work just fine. What is the entry for the light in your Cobfig file?

 "    1": {
                "capabilities": {
                    "certified": true,
                    "control": {
                        "colorgamut": [
                        "colorgamuttype": "A",
                        "maxlumen": 200,
                        "mindimlevel": 10000
                    "streaming": {
                        "proxy": false,
                        "renderer": true
                "config": {
                    "archetype": "huelightstrip",
                    "direction": "omnidirectional",
                    "function": "mixed",
                    "startup": {
                        "configured": false,
                        "mode": "safety"
                "manufacturername": "Philips",
                "modelid": "LST002",
                "name": "deckenlampe-uplight 1",
                "productname": "Hue lightstrip plus",
                "state": {
                    "alert": "none",
                    "bri": 72,
                    "colormode": "xy",
                    "ct": 200,
                    "effect": "none",
                    "hue": 0,
                    "mode": "homeautomation",
                    "on": false,
                    "reachable": false,
                    "sat": 254,
                    "xy": [
            "swversion": "",
            "type": "Color light",
            "uniqueid": "00:17:88:01:00:6f:6c:8f-0b"
    "lights_address": {
        "1": {
            "ip": "",
            "light_nr": 1,
            "mac": "C8:2B:96:2F:3B:85",
            "name": "deckenlampe-uplight",
            "protocol": "native_multi",
            "type": "sk6812_strip",
            "version": 2

Do I need to change the Type to: Color light extended?
Thats how it is with the Yeelight I have.

Well, you can’t control that light at all, can you? Do you see in your config where it says “reachable” is “no”? That’s not good. I would remove the light and re-add it via the hue essentials app. Your settings all match up with mine and I am able to set CT for all of my strips, no problem.

Hi guys, I’d like to continue this topic, because I got the same problem like @Giznae .

I am using a SK6812 strip with the most recent “generic sk6812” code. If I’m controlling the lights with the Hue essential app and request a white color, I get an Orange to Red mix like @Toemmle said. The “(warm)white” is mixed from RGB, the white LED stays off.

But if I am using the webUI or another app like all4hue for request a white color it works fine. The “(warm)white” is then mixed from RGBW.

I am using a 50 w power supply for 77 leds.

So it appears to me that there is a problem with the hue essential app?