Having problems detecting my led strip

Describe the bug
Hello everyone, I am struggling with the latest version of diyHue to detect my led strip. It used to work on an earlier version, I’ve linked some logs, I think there’s a problem with how the IP address is handled by ESPhome (see line 72 of the pastebin).

To Reproduce
Try with the latest build

Expected behavior
It should work like it did a few days ago in an older version of the docker


Additional context

  • Running latest linux docker container to this date on a windows computer
  • Did clean my config.json before hand

With the very very latest version of an hour ago, even if it just add some text to the readme.md file, it doesn’t work…
Here is a full log on pastebin : https://pastebin.com/EvNL7WWY

What’s the ip of the light itself?

I think it’s…
But since it’s going trough the docker, the ip is changed, but used to work before…

You need to use bridged networking for docker to work.

I am using bridge network…
Here is my run command :

docker run -d --name "diyHue" --restart="always" --network="bridge" -v d:/MaxiBerdy/Dockers/hue-emulator/export/:/opt/hue-emulator/export/ -e MAC='2C:56:DC:D6:A6:98' -e IP='' -e 'DEBUG=true' -p 80:80/tcp -p 443:443/tcp -p 1900:1900/udp -p 2100:2100/udp -p 1982:1982/udp diyhue/core:latest; docker attach diyHue

Sorry I meant host networking

But why would it not work anymore if I was able to make it work beforehand ? I use bridged networking because host didn’t work for me the first time I tried to use it…

If you want the technical answer, there is no way to overwrite the automatically detected scan IP for esphome now. Meaning if it cannot detect the correct subnet, it will never find the light. So use host to allow it to see the correct subnet.

Is it impossible to overwrite the IP from esphome since last commit or since much longer time ?
Because I used to run it in bridge mode and it used to work perfectly a few days ago…
Now it doesn’t work and neither it does in host (it is even worse, cannot find the bridge itself from my LAN)

So please tell me there’s actually a bug and not just a misuse from my side…

I fix this bug with commit https://github.com/diyhue/diyHue/commit/8725aaca60664fbdc7cef7353c5eb4003c83a7a3

I don’t believe that commit should have fixed esphome because it uses completely different code. Esphome uses a special yaml that you can find in the lights repository. It appears you are missing the text sensor.

As far as I understood, Marius fixed this with the same patch as for my problem:

Marius did a great job and fixed the Problem in HueEmulator3.py. Line 707:

def generate_unique_id():
rand_bytes = [random.randrange(0, 256) for _ in range(3)]
return “00:17:88:01:00:%02x:%02x:%02x-0b” %
WAS: (rand_bytes[0],rand_bytes[1],rand_bytes[2],rand_bytes[3])
NOW IS: rand_bytes[0],rand_bytes[1],rand_bytes[2])


Yeah @ThomasWho you’re right, he did a good job and solved some issues, but I now have to do a few trials to find my led strip, I find it very strange…