Installation error

I’m trying to install in Docker according to the manual. I have tried cut/paste both command lines (host & bridge network mode) and get the same error message from both:

docker: Error response from daemon: invalid mode: ‘rw’.

How you start the docker container? invalid mode: “rw” looks to be an issue with compose manifest file.

If you can post the exact command your using that would be great. It may be due to the name of the folder your mounting.

Well, I have only copy/pasted the installation commands from the installation guide:

docker run -d --name "diyHue" --restart="always" --network="host" -v '/mnt/hue-emulator/export/':'/opt/hue-emulator/export/':'rw' diyhue/core:latest
docker run -d --name "diyHue" --restart="always" --network="bridge" -v '/mnt/hue-emulator/export/':'/opt/hue-emulator/export/':'rw' -e MAC='XX:XX:XX:XX:XX:XX' -e IP='XX.XX.XX.XX' -p 80:80/tcp -p 443:443/tcp -p 1900:1900/udp -p 2100:2100/udp -p 1982:1982/udp diyhue/core:latest

I tried both host and bridge network mode (with correct MAC and IP addresses) with the same result. I guess it’s the “rw” in the command lines that is referenced in the error message but since I’m not a Docker/Linux guy I haven’t a clue why it sees that as
an error.

Running on Windows 10. Docker is configured for Linux containers. The very first time I ran a command there were some downloads before the error message came but any command after that displays the error message immediately.

Ah your trying to run it on Windows! We have not tested it at all in Windows, even with docker. Your likely to come across bugs. However this issue here is your trying to mount a volume in the folder ‘/mnt/hue-emulator/export/’ this is not a valid directory on your Windows machine. Change it to something like ‘c:\ContainerData\diyHue’

Ah, OK. I thought Docker was a virtual environment that wasn’t dependent on the host.

I should probably drop the whole thing then. Learning Docker, Linux and diyHue and run it all in an untested/unsupported configuration seems a bit overkill to light some bulbs… :slight_smile:

It is and it isn’t. It’s not a whole virtualised system like a virtual machine as it doesn’t virtualise hardware as it shares the host kernel and also relies on on the host for access to certain systems such as the local file system. As such, you need to provide a valid directory on the local system to mount. Another thing provided by the host is the network stack, and as diyhue is very network oriented and built and tested on Linux, you may run into issues.