APP requires Update of Hue Bridge - Update Fails

Recently Hue has updated the Firmware (swversion) of their Bridge.
A new Software Version is introduced.
In general diyhue does not use the swversion. It is only used for emulation.

However: Changing swversion can also imply changes to how things are handled on genuine hardware.

That being said it is possible that updating swversion without changes to diyhue could cause bugs.

In order to Update your swversion follow these steps:


  • Stop Emulator or Docker Container
  • edit config.json
  • in key "config" change "swversion":"XXXXXXX" to "swversion":"1949203030"
  • Note: do not change version in Lights!
  • save
  • restart Service or Docker Container


  • Navigate to your diyhue Web UI
  • Edit Bridge Config via Web UI
API : 1.49.0
Software Version: 1949203030

Update Message should be gone.

Best Practice is to Pull the latest Docker Image and redeploy!

Dev Note: you can set "swversion":"1999999999" to eliminate any future update requests but be advised as this may cause unkown error. :slightly_smiling_face:

Cross Reference:

1 Like

Hi Mevel, i did update the SWversion in the config. The hue app is not asking for the update anymore but has the message making connection and won’t pass that screen now.

Any ideas or suggestions?

same probelem here. Update the swversion nr. the config.json. the app is no longer asking for update but i have no connection to the app

Same problem here. Cant connect DiyHue to the new updated app.

you can try and delete the app cache on Android or reinstall the app on iOS. might be a problem with the certificate then.
we recommend Hue Essentials App for Android and iOS. We are in close contact with the dev.

note: since May and in particular with this swversion the new Hue API v2 is in place. However the new API is reverse engineered at this point and implemented in the beta branch.
you can give it a try
does that work out?

I tried it but without success. But I must say I do like the new UI for diyhue and finally the link with deconz is working for me.

But no success with the Hue App. I like the hue app more than the Hue Essentials App.

Como vc conseguiu?
I am Brazilian

Tentei parear mas pede para atualizar

I am Brazilian

Como faz agora para parear no app hue sem passar pela atualização?

Hey. I just tried the beta branch(armv7-beta), unfortunately with the same outcome. The app cannot connect to the bridge.
The new UI looks great :smiley:

I just got my first hue devices and a hue bridge, and I’m trying to get a diyHue up and running to unify some other lights with the Philips bridge. I’ve followed the steps suggested in the original post, but it’s not working for me. Something I’ve noticed though:

In the Hue app, my genuine Hue Bridge has a software version of 1.45.1945091050.

When I run the docker version of diyHue, I can get the emulated hub up and running. I can see the activation button page at {ip address}/hue/linkbutton, and from the Hue app I can even successfully find and connect to the hub by searching for the ip address, however it demands I update the software on the hub. If I enter 1945091050 then I can see the hub in the Hue app, and I can see the link button page just fine, but it the app still says the software version is wrong.

If I try to enter 1.45.1945091050 into the config.json file, then the docker no longer runs. I can’t see the hub in the app, nor can I access the linkbutton page.

Has Philips changed their software versioning schema? Does the inclusion of the periods break something in the json? I shouldn’t think so since there are a lot of other places where they are allowed.

1 Like

Trying to connect to hue app today after a while it did not work I reinstalled everything still it shows update hue bridge…any help?

What version of diyhue are you using?

try using the latest beta build within docker

installed today on a Raspberry Pi. Performed the changes described at the beginning of this article, same problems. Please help! @Mevel


I updated the first post to reflect the latest Api version and SW version.

In general it is best practise to pull the latest diyhue Beta Image.

API : 1.49.0
Software Version: 1949203030

Thank you for the update. I installed diyHue on a raspberry pi, with the automatic process. Maybe the image connected to that is not the latest? Best

@cinghialino is it working for you now?

In general we suggest using docker as we can easier narrow the error down as we can ship everything that diyhue needs in one container.

well, it’s a step forward. I was able to update the config.json (after I was having problems to get the configuration changes to stay changed, until I read three times again your steps that said to stop the service before changing the configuration)
so now I am:
able to connect the the hub,
I do not receive the update request,
I’m able to click the button on [IP]/hue/linkbutton and having the hub recognize that

The next step would be to complete the inclusion of the hub in the Hue App,
but that’s where I’m stuck, as it keeps trying to connect without ever succeeding.
Maybe because I have an actual hub and this would be a second one (to add wLED lamps)?

I was able to add the hub to “Hue Essential” and to add a light there, but that’s not what I’m looking for.
I want to use the Hue app.

thank you for your support.