Cannot update in app

I have tried to update the bridge in app and it fails. I went on the diyhue website and tried our the command “sudo systemctl restart hue-emulator.service” and it still doesn’t work, I also did “sudo apt update” and “sudo apt upgrade” and it still promoting me to update.

There is an update script in the Hue directory. Just run sudo /opt/hue-emulator/ (I believe, typing it from memory). That will update the software. I believe updating through Hue Essentials is still a work in progress. You won’t be able to update through the Hue App.

Thank you it fixed my issue, you don’t have to run the command as you can just open the file in terminal.

I have the same issue, and this does not work for me. I still have to do the update in the Philips Hue App, but I can’t because the update button is not activate (I can’t click on it). I can’t do anything in the app because of this.

You can’t update the software that way. You have to update the latest version of DIYHue. That will update the software version that the Hue app sees. You can press that button all day long but it isn’t going to update anything because DIYHue doesn’t use the same software as a genuine hue bridge.

Yeah I know, i have updated the latest version of DIYHue before writing my message, and I still had this trouble. A cupple of weeks later and it’s fix, I don’t know why.

I’m having trouble running sudo /opt/hue-emulator/ it’s coming back with command not found. hue app is telling me there is an official update, i know i cant do that update, so am looking to see if there is an update for the diyhue to make the message go away in the app

See other post on how to update emulator

Hi, I’m really sorry but that wasn’t work. I tried to stop emulator, run check_update, reboot, uninstall and reinstall it, same with the hue essential app and the philips hue app. I also tried to modify the config.json.
I can see and use my light strip in the hue essential app, but the Philips hue app still ask me to made the update.

You’ll need to be running the latest version for it to work. Personally I don’t use the native install method and there are plans to depreciate it with the next version in favor of docker.

Maybe try that? IMO its a lot easier to setup and update compared to the native method.