Error in docker image on Raspberry Pi 4


I’m trying to install on a Raspberry Pi which runs Pi-hole, so the default ports are already in use and can’t be changed easily. In order to avoid clashes I tried to create a docker image with a different IP address with:

docker run -d --name diyHue --restart=always --network <network> --ip <new_ip> -e MAC=<mac> -u <user> -v /mnt/hue-emulator/config:/opt/hue-emulator/config diyhue/core:latest

Unfortunately, the docker image crashes with the error message:

Traceback (most recent call last):
  File "/opt/hue-emulator/", line 2, in <module>
    from flask import Flask
  File "/usr/local/lib/python3.11/dist-packages/flask/", line 3, in <module>
    from werkzeug.exceptions import abort as abort
  File "/usr/local/lib/python3.11/dist-packages/werkzeug/", line 1, in <module>
    from .serving import run_simple as run_simple
  File "/usr/local/lib/python3.11/dist-packages/werkzeug/", line 29, in <module>
    from ._internal import _log
  File "/usr/local/lib/python3.11/dist-packages/werkzeug/", line 2, in <module>
    import logging
  File "/usr/lib/python3.11/logging/", line 58, in <module>
    _startTime = time.time()
PermissionError: [Errno 1] Operation not permitted

I have tried several things, to no avail. Any idea what could be the cause and how to fix it?

Please let me know if additional information is needed. Disclaimer: I have no experience with Docker.