Automatic installer using a different port? (not port 80?)

Hello guys,

I’m running deconz on a RB pi 4 and like to run diyhue on this pi as well to get rid of my hue Bridge. The only reason I’m using this bridge is for the entertainment function as there is one hue Ledstrip connected to the bridge wich matches the color with what is on TV, connected to a windows pc running hue sync.

Running the automatic installer give me an error that port 80 is allready used. That’s correct as deconz is also using this port. I’m wondering shy you have choose port 80 for this. Why not 94, 147, 143, 110, or what ever! I think that a lot of people are running deconz as well, so choosing the exact same port as that is not a good idea I think… Before this is solved, can you upload an installer that is trying to install diyhue to a different port maybe? That will be awesome!

Cheers, best regards,

Hello and welcome!
The short answer ist, because official hue bridge uses port 80 and official app only looks on those ports.

To comply with other hue api integrations, diyhue follows those guidelines.

We suggest using deconz GUI and websocket on non default ports.

Hope. That helps

Hi and thanks! That make sense.

I allready tried to find out how to set deconz to another port, but there is no easy way to do that without manually editing files. I’m new into the raspberry pi thing and have no pi skills (yet). Can you maybe explain how to configure the port for deconz?

Best regards,

Have a look at the diyhue documentation. Deconz section

Thanks! Did not find that yet. :slight_smile: I will try it out. First question regarding this manual; how do I “turn off the serial login”? For the record, my deconz installation is up and running.

Start a terminal window and run the command sudo raspi-config

In the config, select Interfacing Options then select Serial.

The next option you will see will be to be able to login over serial. This is what you want to say No to.

However you must say “yes” to the next option to enable serial.

That’s it. Select finish and it should reboot for you.